アクセラと+αな生活
アクセラとα350と共に過ごす気まぐれ日記です。
Firefox ブラウザ無料ダウンロード
2017年06月
≪05月  1  2  3  4  5  6  7  8  9  10  11  12  13  14  15  16  17  18  19  20  21  22  23  24  25  26  27  28  29  30    07月≫
スポンサーサイト
上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。
近頃は結構なサイトでFlashが使われていますね。

Vine ちゃん(VineLinux 4.2)には標準でFlashがセットアップされていないので、セットアップしてみようかと。
特に Flash が必要なのではないけど、開くたびに Flash プラグインをインストールするメッセージに飽きただけです。。。
Vine ちゃん上のFirefox(Firefox 3.0.10)では残念ながら、Firefox のプラグインインストール機能ではセットアップできません。

なので、Flash Player(Linux 用rpm)をダウンロード。
以下のサイトからダウンロード可能です。

【Flash Player 10】
ダウンロード先:http://get.adobe.com/jp/flashplayer/

falsh_01.jpg

ダウンロードが完了したら、早速セットアップしてみます。

(ダウンロードしたファイルの保存ディレクトリで)
# rpm -ivh flash-plugin-10.0.22.87-release.i386.rpm
 エラー: 依存性の欠如:
  glibc >= 2.4 は flash-plugin-10.0.22.87-release.i386 に必要とされています


# rpm -q glibc
 glibc-2.3.4-2vl3.3

ありゃりゃ。。。glibc(Cのライブラリ)が2.4以上が必要なの??
で、セットアップされている glibc のバージョンは2.3のようで。。。

# apt-get upgrade glibc
 パッケージリストを読みこんでいます... 完了
 依存情報ツリーを作成しています... 完了
 アップグレード: 0 個, 新規インストール: 0 個, 削除: 0 個, 保留: 0 個

# apt-get update;apt-get install glibc
 取得:1 http://updates.vinelinux.org 4.2/i386 release [2262B]
 2262B を 0s 秒で取得しました (2999B/s)
 ヒット http://updates.vinelinux.org 4.2/i386/main pkglist
 ヒット http://updates.vinelinux.org 4.2/i386/main release

 ~ 略 ~ 

 ヒット http://updates.vinelinux.org 4.2/i386/nonfree srclist
 パッケージリストを読みこんでいます... 完了
 依存情報ツリーを作成しています... 完了
 パッケージリストを読みこんでいます... 完了
 依存情報ツリーを作成しています... 完了
 * glibc は既に最新バージョンがインストールされています。
 アップグレード: 0 個, 新規インストール: 0 個, 削除: 0 個, 保留: 0 個


うーん、パッケージは2.3が最新のようで、2.3以降は用意されてないようですね。。。
ネットで調べてみると、glibc は2.8とかがあるようです。


困りますね。。。Vine 4.2 は正式リリースされているバージョンなのに、最新の glibc のパッケージが用意されてないなんて。。。><;

とはいえ、こういう対応をしてくれなかったり、対応が遅い、すごく不真面目な Vine Linux が好きな私ww
自分で調べるという面白みがありますしねww

まあ、ソースからビルドすれば、最新の glibc をセットアップできるのでしょうけど。
ソースからのビルドでは、相手がCのライブラリだけに何が起こるか分からないし、今まで動作していたものが動作しなくなるってこともありますので、ビルドは避けたいですね。。。
パッケージとしてリリースされたものであれば、動作検証しているはずなので、リリースパッケージを使うようにしたいですしね。

とはいえ、Flashがセットアップできない。。。どうしよう。。。><;
ソースからの glibc のビルドは対応策から外すとすると、古いバージョンの Flash の使用で回避かなw
Flashのバージョン10が glibc 2.4以上なだけで、古いFlashなら今セットアップされている、glibc 2.3でも動作するのであればいいけど。

とりあえず、Flashのバージョン9がどっかにあるか探してみようww

ってことで、今日はここまでww

コメント
この記事へのコメント
URL :
コメント :
パスワード :
管理者にだけ表示を許可する
 
トラックバック
この記事のトラックバックURL
Template designed by アクセラと+αな生活

Powered by .
上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。